• Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   14-02-2016

      Prezados membros do Fórum do Clube do Hardware,

      Está aberto o processo de seleção de novos moderadores para diversos setores do fórum. Os requisitos são:
        Pelo menos 1000 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas ao formulário abaixo:    Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • dif

      Poste seus códigos corretamente!   22-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Plateu

Dúvida na criação de uma placa com o módulo GSM SIM900

161 posts neste tópico

Boa noite, pessoal, tudo bem?

Estou desenvolvendo uma plaquinha para o módulo SIMCOM SIM900 a partir do módulo que comprei no eBay. Lendo o datasheet fornecido pelo fabricante, tive algumas dúvidas. São elas:

1) Como fazer a fonte de tensão se preciso prover, no mínimo, 2A em caso de rajadas?

O fabricante sugere uma montagem que usa um regulador linear de baixo dropout e que regula para 4.1v (MIC29302WT). Segundo as especificações, pode ser usado qualquer regulador de tensão linear que siga as especificações. Entretanto, qual poderia usar visto que o sugerido ẽ impossĩvel de encontrar?

Esquema:

bc46226b.png

2) Qual diodo zener usar na proteção do SIM CARD?

O fabricante pede para usar um bendito array de proteção composto por diodos zener (segundo o datasheet). Entretanto, o valor destes não é mencionado. Encontrei um esquema na net em que o tal array (SMF05C) é substituido por 4 diodos zener de 5.1v.

Lendo o datasheet, o fabricante sugere que pode ser usado o tal SMF05C ou o ESDA6V1W5. Pesquisando o datasheet deste ultimo, me parece que os zeners usado são de 6 ou 6.1v, se é que existe estes valores comerciais.

Sendo assim, qual usar?

07567a26.png

61f185ee.png

Um grande abraço a todos,

Pedro Rosa!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fuçando um pouco no Google encontrei o seguinte esquema:

6hAAAAAElFTkSuQmCCreguladordepotencia.png

O que vocês me dizem deste? Eu poderia trocar o 78XX por um LM317 e regular para 3,8~4v?

Abraço,

Pedro Rosa!

Editado por Plateu

Compartilhar este post


Link para o post
Compartilhar em outros sites

"...fonte de tensão se preciso prover, no mínimo, 2A em caso de rajadas?". Rajadas seriam picos?

Para esta fonte linear precisa, você pode utilizar o LM350, pois o LM317 é limitado a 1,5A.

Ah! as suas fotos não estão aparecendo.

Ricardospimentel

Compartilhar este post


Link para o post
Compartilhar em outros sites
"...fonte de tensão se preciso prover, no mínimo, 2A em caso de rajadas?". Rajadas seriam picos?

Para esta fonte linear precisa, você pode utilizar o LM350, pois o LM317 é limitado a 1,5A.

Ah! as suas fotos não estão aparecendo.

Ricardospimentel

Aqui as fotos aparecem normalmente, basta clicar no Mostrar.

De acordo com o datasheet, pode ser necessários 2A de corrente (acredito ser sim de pico) quando ocorrer rajadas de transmissão. O kit de desenvolvimento quando é vendido acompanha uma fonte de 5V/2A justamente por isso.

O lance que eu havia dito de combinar um transistor de potencia PNP, tal como o TIP42, e um regulador de tensão, tal como o LM317, era para usar o regulador para se chegar a uma tensão desejada (algo em torno de 3,8~4,1v) mas fornecendo mais que os 1,5A do LM317, sendo essa corrente controlada pelo TIP42.

Uma outra questão que poderia ser colocada é trocar o TIP42 por um Darlington, algo como o TIP141.

Se alguém não conseguir ver as fotos eu as anexei no tópico.

post-16855-13884962035447_thumb.jpg

post-16855-13884962035955_thumb.jpg

post-16855-13884962036224_thumb.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro amigo Plateau, as imagens a que me referi são aquelas que postaste no post seguinte, o de nº #2, sendo assim imagino que o lance do PNP esteja implícito nessas figuras.

Veja esta citação de nosso amigo Faller que trata justamente sobre isso, suas explicações beiram a excelência.

Mas que seja, use o LM317... Se a corrente que ele maneja não for de tamanho suficiente para que o mesmo atenda suas exigências, adote um regulador by-pass do mesmo.. Entendendo do que se fala...

Esse regulador se baseia no seguinte princípio:

LM317comBy-pass.jpg

A corrente I LM317, enquanto não estabelecer sobre aquele resistor de entrada uma queda igual ou maior a VBE (tipicamente 0,6 Volts) não circulará corrente sobre o transistor PNP, e desse modo o LM317 se comportará como se sozinho estivesse. A partir do momento em que a corrente exigida pela carga for de tamanho suficiente para que essa queda ponha o transistor em operação, ele passará a ofertar parte da corrente da saída. Aquele valor de 0,6 Ohms da entrada está mais ou menos calculado para que a partir de 1 Ampere em cima do LM317 o transistor passe a ajudar by-passando corrente... Simples, não???

Problema:

O LM317 é praticamente indestrutível, a prova de idiotas, ele tem limitação de corrente e além disso tem limitação térmica.... Mas o transistor não... Desse modo a corrente de saída, se aumentar de um modo descontrolado, via transistor, esse poderá se danificar.. O que fazer??

Duas alternativas de proteção as quais aconselho adotar:

1) Termicamente proteger o transistor. A aposição do LM317 no mesmo dissipador do transistor, o quanto mais juntos melhor, e com o melhor acoplamento térmico que se consiga oferecer, fará com que ao aquecimento desmesurado do transistor aqueça também o LM317, fazendo-o entrar na zona de proteção térmica, cortando desse modo também o transistor..

2) Por corrente proteger o transistor, de uma modo muito simples, com a adição de um simples resistor a mais.. Veja o esquemático agora:

LM317comBy-passprotegido.jpg

Viste ali a inserção de um novo resistor no emissor do transistor de by-pass. Alteraram-se os valores. Agora, ao passar por exemplo 1 Ampere pelo LM317, se estabelecerá no resistor de 1 ohm a tensão de 1 Volt.. Desse 1 volt, 0,6 ficarão no VBE para garantir a condução do transistor e os restantes 0,4 Volts ficarão sobre o resistor de 0,1 ohm... Mas a velha lei de ohm me diz que 0,4 Volts sobre 0,1 Ohm significam 4 Amperes pelo transistor de By-pass e 1 Ampere pelo LM317, totalizando 5 Amperes ai na saída...

A corrente pelo transistor não vai aumentar pois se aumentar sobe a queda sobre o resistor de emissor do mesmo e ele tenderá a se cortar..

Claro que toda essa explicação é meramente para que se possa entender. Muitas mais variáveis estarão em jogo, mas sempre ao nosso controle através da correta colocação dos valores desses resistores. Pouco a mais pouco a menos e se tem uma variação bem grande na faixa útil da fonte..

Isso dai é simplificar entendendo o porque das coisas e não simplesmente adotando esquemáticos meio que de bancada..

Como escolher o transistor PNP... Escolha algum que possa estar a mão, de boa capacidade de corrente. No mínimo 2 a 3 vezes a corrente limite de seu uso..

Imagino que um LM317T é capaz de aguentar alguns surtos de 2A ou até mesmo é capaz de alimentar um circuito com essa corrente sem arriar.

Segundo o Datachite da National, ele aguenta tipicamente 2.2A quando Vin - Vout <= 15V a 25°C, sendo 1,5A a corrente mínima para ele e 3,4A a máxima. É o caso de se fazer testes com ele, e garantir em sua entrada uma tensão de 2 a 3 volts maior que a saída e também usar todos os diodos de proteção.

Ricardospimentel

Compartilhar este post


Link para o post
Compartilhar em outros sites
Caro amigo Plateau, as imagens a que me referi são aquelas que postaste no post seguinte, o de nº #2, sendo assim imagino que o lance do PNP esteja implícito nessas figuras.

Veja esta citação de nosso amigo Faller que trata justamente sobre isso, suas explicações beiram a excelência.

Imagino que um LM317T é capaz de aguentar alguns surtos de 2A ou até mesmo é capaz de alimentar um circuito com essa corrente sem arriar.

Segundo o Datachite da National, ele aguenta tipicamente 2.2A quando Vin - Vout <= 15V a 25°C, sendo 1,5A a corrente mínima para ele e 3,4A a máxima. É o caso de se fazer testes com ele, e garantir em sua entrada uma tensão de 2 a 3 volts maior que a saída e também usar todos os diodos de proteção.

Ricardospimentel

Obrigado pela explicação, Ricardo.

A imagem que eu me referia era esta aqui:

http://www.ibytes.com.br/imagens/reguladordepotencia.png

Entrando com 12/14v da bateria do carro ou 12v de uma fonte AT essa configuração do LM317 + TIP42 ficaria legal para oferecer os eventuais 2A de corrente nas rajadas? Fora esse pico de 2A, o módulo costuma consumir algo na casa dos 200mA em chamadas de voz, que é o mais consome. Sendo assim, quando não for exigido os 2A, o LM317 forneceria os 200mA necessários ou sempre teriamos mais corrente devido ao TIP42 estar by-passando?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro amigo Plateau.

Eu acho, só que eu acho e ainda tô achando que neste caso, o CI em questão sozinho já será capaz de fornecer energia para o seu circuito, segundo o datachite, mas caso ache que ela irá falhar, ou use o LM350 (3A normais) ou então utilize o Shunt com o TIP42 (6A).

No caso de se utilizar o circuito drenando 200mA com 14V na entrada teremos:

14V - 3,8V (aqui estou utilizando a sua Vmin sugerida) = 10,2V

200mA

10,2V ÷ 0,200A = 2,04W de dissipação e com ...

2A

10,2V ÷ 2A = 20,40W.

Veja que se o teu circuito exigir muito dessa potência por muito tempo, terás de providenciar um bom dissipador com um arrefecimento forçado. 25W é potência de ferro de solda!

Caso você utilize o LM350 ou faça a fonte com o TIP42, a potência dissipada geral será semelhante. Se isso for problema parta para uma solução chaveada do tipo buck-down.

Se você fizer o circuito com by-pass, poderá dividir 1A para o LM e 1A para oTIP, só que o TIP só entrará em ação quando o limite de 1A do LM for ultrapassado.

Ricardospimentel

Editado por ricardospimentel

Compartilhar este post


Link para o post
Compartilhar em outros sites
Caro amigo Plateau.

Eu acho, só que eu acho e ainda tô achando que neste caso, o CI em questão sozinho já será capaz de fornecer energia para o seu circuito, segundo o datachite, mas caso ache que ela irá falhar, ou use o LM350 (3A normais) ou então utilize o Shunt com o TIP42 (6A).

No caso de se utilizar o circuito drenando 200mA com 14V na entrada teremos:

14V - 3,8V (aqui estou utilizando a sua Vmin sugerida) = 10,2V

200mA

10,2V ÷ 0,200A = 2,04W de dissipação e com ...

2A

10,2V ÷ 2A = 20,40W.

Veja que se o teu circuito exigir muito dessa potência por muito tempo, terás de providenciar um bom dissipador com um arrefecimento forçado. 25W é potência de ferro de solda!

Caso você utilize o LM350 ou faça a fonte com o TIP42, a potência dissipada geral será semelhante. Se isso for problema parta para uma solução chaveada do tipo buck-down.

Se você fizer o circuito com by-pass, poderá dividir 1A para o LM e 1A para oTIP, só que o TIP só entrará em ação quando o limite de 1A do LM for ultrapassado.

Ricardospimentel

Entendido, Ricardo. O TIP42 só vai by-passar se a corrente de 1,5A do LM317 for superada. O que eu pretendia era usar o que tinha em casa e não ter que comprar nada. Se esse LM350 não for muito caro eu compro ele mesmo e o utilizo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não querendo fazer propaganda da Multcomercial, mas: http://loja.multcomercial.com.br/ecommerce_site/produto_8561_4689_Circuito-Integrado-Regulador-LM350T, mas essa loja é daqui de São Paulo entretanto ela faz envio também, mas deve ter lojas com preços bons por aí também. Quando fiz serviço em Barreiro, precisei de alguns componentes e tinha umas lojinhas lá na Sinfrônio Machado, acho que no centro de BH tenha mais opções, andei muito pouco por aí e só conheço a Amazonas e a praça da estação.

O valor dele é deveras um pouquinho maior que o pack LM317 + TIP41 + resístores de potência, entretanto seu circuito ficará bem mais simplificado.

Ricardospimentel

Editado por ricardospimentel

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vou ver se dou um pulo no centro amanha e olho isso. Belo Horizonte é meio uma roça iluminada e as eletrônicas daqui só tem o trivial que toda eletrônica deveria ter. Esses dias fui atrás de um MAX232 e nenhuma loja dizia ter.

No site que você mostrou ai tem dele por R$4,50. Creio que deva ser mais ou menos isso mesmo por aqui. No ML tinha dele por R$3,00 mas o frete não valia a pena.

Mais uma vez, obrigado pela ajuda, Ricardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Uma loja virtual que o povo tá recomendando bem é a Soldafria.

Aqui o tópico atual em que o pessoal tá comentando sobre ela : http://forum.clubedohardware.com.br/loja-online/1021393.

O site deles é: http://www.soldafria.com.br/.

...mas o da Multcomercial também é bem comentado.

Tá aí um novo horizonte pra você comprar peças.

Ricardospimentel

Compartilhar este post


Link para o post
Compartilhar em outros sites

Montei só com o LM317 e funcionou beleza.

Só não tô conseguindo registrar o chip na rede VIVO, e em outras também. hehehehe

Compartilhar este post


Link para o post
Compartilhar em outros sites
Montei só com o LM317 e funcionou beleza.

Só não tô conseguindo registrar o chip na rede VIVO, e em outras também. hehehehe

Te mandei um email e uma MP falando sobre o possível problema disso, Geovane. Se puder, me responde lá que talvez eu consiga te ajudar.

Abraço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Baixei vários esquemas, fiz bastante pesquisa pra começar montar a placa, o que deu mais trabalho foi na hora de comunicar com o PC via Serial.

Mais encontrei o problema, minha fonte só fornecia 3.06 volts, isso fez com que o Led do NetLight ficasse aceso constantemente e não consegui comunicação serial.

Observando o datasheet do SIM900, ele trabalha com uma range de tensão de 3.2V a 4.8V, então olhando a tabela de configuração de voltagens do LM317, troquei os resistores pra fornecer 3.83 volts, então quando precionei o botão do POWERKEY, pronto, o sistema levantou o serviço, tive acesso serial sem problemas e o Led do NetLight começou a piscar, fiz uma pesquisa no nível de sinal da operadora, ele me respondeu que tava 18,0 e 20,0, por visto um sinal muito bom.

Agora não consegui registrar as operadoras como havia reportado anteriormente.

Tô pesquisando e testando os comandos AT, acredito que seja apenas configuração agora.

Plateu, tudo bom com você colega? É o seguinte, eu tenho uma porção de circuitos que baixei na net, pra estudar qual o melhor pra começar a montar, só que tive que eliminar algumas partes que não me atendia, desenhei a placa usando o PCBExpress, comprei umas tintas profissionais pra revelação fotográfica, adquiri os componentes, então meti bronca.

Tô usando o SIM900, juntamente com o GPS-ME1000 e um pic da Tato, o Basic Step M8 (programado em Basic), tudo isso pra montar um rastreador veicular.

Graças a DEUS, já estou finalizando.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Plateu, como você pode observar nesse circuito, ele não utiliza esse array, usa apenas os resistores de 22 R e alguns capacitores associados.

Como é uma placa Beta, fiz apenas com os capacitores mesmo, e não usei resistores de 22 R, usei de 33 R, motivo pelo qual, não encontrei em minha sucata, rsrsrsrsrsr.

É isso aí Plateu, boa sorte na montagem, lembre que a parte mais difícil do projeto é iniciá-lo, o restante é mais fácil.

Um forte abraço à todos.

Até mais.

post-955494-13884962039658_thumb.png

1 pessoa curtiu isso

Compartilhar este post


Link para o post
Compartilhar em outros sites

Já havia visto este esquema em algum lugar, Geovane.

Contudo, o que você me diz desse aqui:

http://www.open-electronics.org/small-breakout-for-sim900-gsm-module/

É o que estou usando para basear o meu projeto que estou a desenhar no Eagle.

Uma coisa que me intrigou nesse seu esquema é o pino POWERKEY estar sempre em nivel lógico alto. QUal a razão disso?

Att,

Pedro Rosa!

Uma outra questão é: Para comunicar com o PIC você precisou colocar um conversor de nível tal como o MAX232 ou ele só seria necessário se eu for comunicar com o PC?

Editado por Bcpetronzio
Unir Post seguidos em menos de 24 horas, use a opção editar

Compartilhar este post


Link para o post
Compartilhar em outros sites

Detalhe, na imagem o módulo que está indicado é o SIM300, mas pode montar com o SIM900 que dá certo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia à todos!

Plateu é o seguinte, o POWERKEY só liga o módulo quando vai a nível baixo e esse esquema que mostrei a você, não é exatamente o que eu trabalho, mostrei esse pra focar o problema do array de diodos, pra você ver que não precisa dele "entre aspas", pelo menos por enquanto, pra colocar pra funcionar, tive que fazer assim, porque não os encontrei. mas se tiver em mãos, aconselho a utilizá-lo, pois eles protegem o SIMCARD.

Bom em relação a comunicação, uso um MAX232 pra converter RS232/LVTTL, senão o módulo não conversa com o mundo exterior.

Agora se você for comunicar com um PIC, aí vai ter que mudar pra TTL(5V) ao invés de LVTTL(3V). Há menos que esteja alimentando o PIC com a mesma tensão do módulo SIM900 ou seja (3 volts e alguma coisa).

Veja o esquema origial no datasheet do SIM900, esse é o circuito que você deve montar pra ligar o módulo.

Boa sorte.

Veja na imagem:

Existem os dois modos: Manual e automático.

Manual: Usando o Pushbutton pra ligar.

Automático: Usa o circuito pra ligar, usando um PIC, você programa um pino para saída e coloca em nível ALTO durante 2 segundos, depois volta pro nível BAIXO.

Pronto toda vez que você ligar o conjunto, o PIC vai ligar o módulo do SIM900 pra você automaticamente.

Um forte abraço à todos.

Esse circuito que vovê mostrou funciona também.

Não esqueça de verificar a pinagem do SIMCARD que você vai utilizar, pois tem umas que são diferentes, por exemplo, no circuito proposto, o pino 5 vai ao GND, aqui no meu circuito, quem vai pro GND é o pino 4, além de outras particularidades nas pinagens.

Cuidados devem ser tomados pra não queimar o CHIP.

Boa sorte.

Você viu o array de diodos na placa desse projeto?

Procurei ele, mais não encontrei!

post-955494-13884962051331_thumb.jpg

Editado por Bcpetronzio
Unir Post seguidos em menos de 24 horas

Compartilhar este post


Link para o post
Compartilhar em outros sites
Existem os dois modos: Manual e automático.

Manual: Usando o Pushbutton pra ligar.

Automático: Usa o circuito pra ligar, usando um PIC, você programa um pino para saída e coloca em nível ALTO durante 2 segundos, depois volta pro nível BAIXO.

Pronto toda vez que você ligar o conjunto, o PIC vai ligar o módulo do SIM900 pra você automaticamente.

Um forte abraço à todos.

Esse circuito que vovê mostrou funciona também.

Não esqueça de verificar a pinagem do SIMCARD que você vai utilizar, pois tem umas que são diferentes, por exemplo, no circuito proposto, o pino 5 vai ao GND, aqui no meu circuito, quem vai pro GND é o pino 4, além de outras particularidades nas pinagens.

Cuidados devem ser tomados pra não queimar o CHIP.

Boa sorte.

Você viu o array de diodos na placa desse projeto?

Procurei ele, mais não encontrei!

Entendi, Geovane.

No caso eu vou usar um PIC18F4680 ou um 18F4550. Ambos são alimentados por 5v. Nesse caso, eu precisaria colocar um MAX232 para fazer o SIM900 comunicar com o PIC? Eu imaginava que usar o MAX232 só seria necessário se eu fosse comunicar com o PC (até estou montando uma plaquinha separada com um MAX232, 2 saidas e 2 entradas com DB9-F).

Em relação a proteção do SIM Card, consegui em um forum russo uma informação de que podemos usar diodos zener de 5V1 como proteção.

Uma outra questão é a seguinte: Arrumei aqui um cabo extensor de antena com conector de rosca para antena (igual em um router) e na outra ponta tem aquele plug pequeno (acho que é SMA) que normalmente tem nas placa de rede wireless de notebook. Como não tenho esse conector SMA, pensei em desmanchar o cabo e pegar os 2 fios e conectá-los normalmente; sendo o principal no pino 60 (RF Antenna) e a malha no terra (GND). Antes de fazer isso, estou seguindo a dica do tutorial de fazer um casamento das impedâncias colocando 2 capacitores de 100pF e 2 resistores de 1K para melhorar o sinal. Por acaso você fez algo assim?

Abraço,

Pedro Rosa!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Acho que não precisa não, porque em todos os circuitos que vi, nenhum dele tinha esse casamento de impedância, e outra, tem uns circuitos que a antena já é feita na própria trilha do circuito impresso. tipo um sinal digital.

Usei um conector de rádio wireless de internet, tirei o conector e liguei uma anteninha que vem com ele, tô dentro do laboratório, o sinal chega 18, 19, 20, muito bom por sinal.

A escala é quanto mair o número, mais ruim é a recepção, vai até 99.

Editado por geovanepc

Compartilhar este post


Link para o post
Compartilhar em outros sites
Acho que não precisa não, porque em todos os circuitos que vi, nenhum dele tinha esse casamento de impedância, e outra, tem uns circuitos que a antena já é feita na própria trilha do circuito impresso. tipo um sinal digital.

Usei um conector de rádio wireless de internet, tirei o conector e liguei uma anteninha que vem com ele, tô dentro do laboratório, o sinal chega 18, 19, 20, muito bom por sinal.

A escala é quanto mair o número, mais ruim é a recepção, vai até 99.

Vou desmanchar o cabinho e ligar como havia proposto antes. Esses dias tive que desmontar um DLink 524G e vi que fizeram exatamente isso. Quanto a questão do MAX232, eu realmente vou precisar usá-lo para comunicar com o PIC18F4550/PIC184680?

Nesse forum russo aqui: http://translate.google.com/translate?sl=ru&tl=en&js=n&prev=_t&hl=pt-BR&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwe.easyelectronics.ru%2Fpart%2Fgsm-gprs-modul-sim900.html&act=url

O cara diz ter usado o MAX232 somente para comunicar o SIM900D (mesma coisa que o nosso mas com menos pinos) e o µController usado por ele era um 8051. Nesse forum ai tem muita informação bacana sobre o Custom Kit.

Dica: Se você souber inglês fica mais fácil entender as coisas desse forum porque a tradução para português (sugestão do Google) fica um lixo total e a tradução de russo para inglês fica show de bola, uma maravilha para ler.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Geovane, qual programa você usou para desenhar? Estou tendo muita dificuldades em desenhar a PCB (o esquema eu já fiz) no Eagle.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Usei o ExpressPCB.

Outra coisa, tirei os capacitores de filtro do SIMCARD, deixei só o da alimentação, coloquei os resistores de 22R originais que tá no esquema e o array de diodos, eu montei com 4 diodos zener de 5v1, funcionou legal.

Já consegui registrar a operadora na rede, agora não tô conseguindo ainda é fazer ligação, tá me retornando NO CARRIER, mais já recebo ligações com bina e tudo.

Já tô quase terminando.

Graças a DEUS.

Um forte abraço à todos.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Usei o ExpressPCB.

Outra coisa, tirei os capacitores de filtro do SIMCARD, deixei só o da alimentação, coloquei os resistores de 22R originais que tá no esquema e o array de diodos, eu montei com 4 diodos zener de 5v1, funcionou legal.

Já consegui registrar a operadora na rede, agora não tô conseguindo ainda é fazer ligação, tá me retornando NO CARRIER, mais já recebo ligações com bina e tudo.

Já tô quase terminando.

Graças a DEUS.

Um forte abraço à todos.

Que bom que deu tudo certo, Geovane. Por acaso você poderia me passar os desenhos que você fez no ExpressPCB?

Esse problema de "NO CARRIER" é quando o recebedor da ligação (p/ quem você está ligando) não atende ou dá tom de ocupado. Uma outra possibilidade é a descrita nesse forum aqui:

http://www.edaboard.com/thread207114.html

Resposta do usuario: "Problem solved. Didn't realize I needed a semicolon at the end to initiate a voice call." --> Problema resolvido. Não imaginei que eu precisava de por ponto e virgula no final para inicializar a chamada de voz.

Não sei se isso serviria para você, mas confere ai.

Última coisa: Você está usando algum programa para simular um terminal ou está fazendo isso com algum micro controlador? Se for com µC você poderia me passar o código para comparar com o meu?

Um grande abraço,

Pedro Rosa!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Plateu, essa mensagem eu já tinha lido pela pesquisa no google, o erro que o usuário tá reportando é do código desenvolvido em C, falta um "ponto e vírgula" no código;

O programa que emula o terminal de acesso à serial, que faz acesso ao módulo, eu mesmo que desenvolvi em Delphi, porque fui usar o Hiperterminal do Windows, mais tava lento demais e travando a máquina, então resolvi usar um que já tinha desenvolvido.

Outra coisa, como fiz uma placa beta, o desenvolvimento da placa que fiz no ExpressPCB já tem que sofrer várias alterações, inclusive no módulo de conversão de RS232 para LVTTL, porque havia feito com 2 transistores NPN, em uma configuração clássica, mais tive que mudar pro MAX232, haja visto que não funcionou satisfatóriamente, mais mudanças aconteceram ao redor do conjunto SIMCARD, que foi justamente a troca dos capacitores pelos diodos zener.

Outra coisa que testei que não funcionou foi a interface do Mic e do Speaker, do Mic não prestou, porque ficou muito baixo a captação do audio, já o Speaker, eu fiz um aplificador operacional com o LM358 pra melhorar o audio, mais a impedância ficou a desejar.

Posso mandar sim, só que acho que você vai ter muito de modificar, e outra, acredito piamente que, como você já desenhou no Eagle, agora só falta mandar o routeador fazer o resto, depois é só ajustar alguns componentes, nada melhor do que os desafios pra aprimorar a habilidade com as ferramentas de trabalho, não acha?

Editado por geovanepc

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar agora