Mallakabadu

Problemas ao acessar Servidor Apache Tomcat 6.0.18

2 posts neste tópico

Pessal, estou com uma grande dúvida.

é o seguinte, tenho uma aplicação java web, com servlets e Jsp's desenvolvida

na IDE Netbeans 6.0.1, fui implantar a mesma num Servidor Apache Tomcat 6.0.18

1º instalei a JRE - jre-6u11-windows-i586-p-s

2º instalei o tomcat

3º Instalei o MySql que é o SGBD utilizado

4º Fiz deploy do meu arquivo *.war no tomcat via interface gráfica

acessado por http://localhost:8084/

até ai tudo bem, fiz esses procedimentos em casa em um computador

como sendo o servidor, e fiz uma rede ponto-a-ponto com um cabo cross,

e ligo o notebook na rede

ai consigo acessar e usar tranquilamente a aplicação que esta no outro

computador ("Servidor") através do endereço:

http://nomeDoServidor:8084/nomeDaAplicação

ex: http://Mallakabadu:8084/Gerencial

agora vem a dúvida....

quando faço esses mesmo procedimentos em uma empresa na qual vou instalar a aplicação, as máquinas ligadas na rede interna, não conseguem acessar o servidor do tomcat na qual está minha aplicação.

a rede dispõe de 1 Hub - 1 modem para ADSL - 1 Access Point somente

e todos os computadores estão ligados ao mesmo HUB

quando tento acessar a aplicação, no caso

http://nomeDoServidor:8084/nomeDaAplicação

aparece que nao existe, não acha a aplicação, no Servidor no qual a aplicação está instalada, eu consigo acessar a usar tranquilamente,

apenas as máquinas da rede não acessam, o estranho é que todas máquinas da rede acessam os arquivos do servidor normalmente, ou seja, elas se veem na rede, acredito eu que o problema esteja na confirguração do tomcat

ai vem minha dúvida:

1º Preciso fazer alguma configuração no tomcat para que os terminais possam

acessar minha aplicação?? se sim, qual configuração??

2º Preciso fazer alguma configuração nas maquinas que estão tentando acessar o tomcat no servidor ??? se sim, qual configuração??

estranho que o mesmo procedimento que fiz para testes em casa funciona,

mais na hora que faço do mesmo jeito para implantar na empresa nao consigo acessar o servidor das máquinas que estão na rede

Espero que entendem minha dúvida

desde já agradeço

Compartilhar este post


Link para o post
Compartilhar em outros sites

putz

era uma simples liberação de porta no firewall

acessado pelo painel de controle> Central de Segurança

ai no firewall do windows na aba de excessões foi add a porta do tomcat

e beleza resolvido

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar agora